Slowdown in Reporting Service
Incident Report for Mersive Technologies
Resolved
This incident has been resolved.
Posted Aug 10, 2019 - 15:30 UTC
Update
We are continuing to investigate this issue.
Posted Aug 10, 2019 - 15:30 UTC
Investigating
We are currently investigating this issue.
Posted Aug 09, 2019 - 15:59 UTC
This incident affected: Device Licensing Service.